На Cisco поднимаем клиента L2TP

И так есть задача поднять L2TP тунель до нашего корневого роутера — и далее поднять VoIP  , так как у клиента стоит Yota и как я понимаю через нее VoIP просто так работать не хочет (то односторонняя слышимость то есче что нить …) так же не работают VPN тунели и т.д , для решения этого вопроса необходимо получить внешний IP у Yota и далее хоть VoIp , хоть VPN — в общем что душе угодно .

Реализация была на Cisco 871

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname voip-client
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging console
enable secret 5 $1$l58F$8cDXC2qVM.XXXXXX
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default none
!
!
aaa session-id common
clock timezone MSK 4
!
!
dot11 syslog
ip source-route
no ip gratuitous-arps
!
!
!
!
ip cef
no ip domain lookup
ip name-server 8.8.8.8
ip multicast-routing
no ipv6 cef
l2tp-class telenet
!
!
multilink bundle-name authenticated
!
!
!
username admin privilege 15 secret 5 $1$Lnpk$W.XXXXXXXXXXXXX
username +sysman privilege 15 secret 5 $1$DLT7$XXXXXXXXX
username test privilege 15 password 0 XXXXXXXXXXX
!
!
!
archive
 log config
  logging enable
  notify syslog contenttype plaintext
  hidekeys
!
!
pseudowire-class class1
 encapsulation l2tpv2
 protocol l2tpv2 telenet
 ip local interface FastEthernet4
!
!
!
!
interface FastEthernet0
 description link to Vioce Gateway
 switchport access vlan 2
 no cdp enable
!
interface FastEthernet1
 description Client Port
 no cdp enable
!
interface FastEthernet2
 description Client Port
 no cdp enable
!
interface FastEthernet3
 description Client Port
 no cdp enable
!
interface FastEthernet4
 description wan link
 ip address dhcp
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
!
interface Virtual-PPP1
 ip address negotiated
 ip mtu 1400
 ip virtual-reassembly
 no peer neighbor-route
 no cdp enable
 ppp pfc local request
 ppp authentication chap ms-chap ms-chap-v2 callin
 ppp chap hostname XXXXXXXXXXXXXX
 ppp chap password 0 weC7XXXXXXXXXXXX
 pseudowire 217.28.208.2 10 pw-class class1
!
interface Vlan1
 description Client net
!
interface Vlan2
 description VOIP
 ip address 172.X.X.1 255.255.255.0
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 172.16.10.0 255.255.255.0 Virtual-PPP1
ip route 217.X.X.X 255.255.255.255 Virtual-PPP1
ip route 217.X.X.0 255.255.255.0 Virtual-PPP1
no ip http server
no ip http secure-server
!
!
!
ip access-list extended WAN
 permit ip any any
!
logging trap debugging
logging facility local2
access-list 10 permit 172.X.X.X
access-list 23 permit 217.X.X.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
snmp-server community public RW 10
!
control-plane
!



^C
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 access-class 23 in
 exec-timeout 35791 0
 escape-character 27
!
scheduler max-task-time 5000
end

Вот как то так , в данной конфигурации нет выхода в интернет , есть только тунель до офиса через L2TP и далее по этому тунелю работает VoIP  вот и все .