Install Nexus5k and initial confioguration

В данной статье будет рассмотрена инсталяция Nexus 5k и первичная его конфигурация . И так приступим к работе , далаем сетевой доступ до железки

 

interface mgmt0
  description switch Gig1/0/8 
  ip address 10.100.X.X/X
!
vrf context management
  ip route 0.0.0.0/0 10.100.X.X

Update software NX-OX


copy ftp://192.168.X.X/soft/Firmwares/CISCO/n5000/n5000-uk9-kickstart.6.0.2.N1.1.bin bootflash:

copy ftp://192.168.X.X/soft/Firmwares/CISCO/n5000/n5000-uk9.6.0.2.N1.1.bin bootflash:

install all kickstart bootflash:///n5000-uk9-kickstart.6.0.2.N1.1.bin system bootflash:///n5000-uk9.6.0.2.N1.1.bin

!

Images will be upgraded according to following table:

Module       Image         Running-Version             New-Version  Upg-Required

------  ----------  ----------------------  ----------------------  ------------

     1      system             5.2(1)N1(1)             6.0(2)N1(1)           yes

     1   kickstart             5.2(1)N1(1)             6.0(2)N1(1)           yes

     1        bios      v3.6.0(05/09/2012)      v3.6.0(05/09/2012)            no

     1      SFP-uC                v1.0.0.0                v1.0.0.0            no

     1   power-seq                    v5.0                    v5.0            no

     2   power-seq                    v1.0                    v1.0            no

     3   power-seq                    v1.0                    v1.0            no

     1          uC                v1.0.0.2                v1.0.0.2            no

 

Базовая конфигурация

 

feature telnet

feature tacacs+

feature interface-vlan

feature lacp

feature vpc

feature lldp

banner motd Z

Authorized Access Only!




service unsupported-transceiver

errdisable recovery interval 90

errdisable recovery cause link-flap

errdisable recovery cause bpduguard

no ip domain-lookup


interface eth1/1 - 48, eth 2/1-16, eth 3/1-16

  shutdown

  description free

  lacp rate fast

  switchport

  switchport mode trunk

  switchport trunk allowed vlan none

  storm-control broadcast level 20.00

- VRF



vrf context FE

vrf context management

 ip route 0.0.0.0/0 10.100.X.X



- LINE 

line console

  exec-timeout 10

line vty

  session-limit 5

  exec-timeout 10

  access-class XXXX

- USER


username admin password 5 PASSWORD  role network-admin

username adminr password 5 PASSWORD  role network-admin


- SNMP

snmp-server contact K1

snmp-server location  K1

no snmp-server tcp-session auth

snmp-server user admin network-admin auth md5 0x942297a priv 0x942297a93104b1b848a4f9a4701e17a1 localizedkey

snmp-server user adminr network-admin auth md5 0x942297a priv 0x942297a93104b1b848a4f9a4701e17a1 localizedkey

snmp-server context FE vrf FE

snmp-server context test

snmp-server context default instance 3

snmp-server community onero group network-operator

snmp-server community ospf2 group network-operator

snmp-server mib community-map onero context default

snmp-server mib community-map ospf2 context FE

snmp-server community onero use-acl XXX

snmp-server community ospf2 use-acl XXX

- AAA



tacacs-server host 192.168.XX.XX key 7 "Ko98" 

aaa group server tacacs+ tacacsVRF 

    server 192.168.XX.XX 

    use-vrf management

aaa authentication login default group tacacsVRF 

aaa authentication login console local 

aaa authorization commands default group tacacsVRF local 

aaa accounting default group tacacsVRF 

tacacs-server directed-request

Обновление софта и базовая конфигурация выполнена , после этих базовых вещей уже будут раскатаны конкретные конфигурации под конкретные нужды